请选择 进入手机版 | 继续访问电脑版

数字之家

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
热搜: 活动 交友 discuz
查看: 578|回复: 0

微擎2.0版本解决自己开发的应用模块无法升级的办法

[复制链接]
  • TA的每日心情
    开心
    2019-5-30 08:42
  • 签到天数: 10 天

    [LV.3]偶尔看看II

    493

    主题

    498

    帖子

    2293

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    2293
    admin实名认证 发表于 2019-3-13 22:49:36 | 显示全部楼层 |阅读模式
    从1.8升级到2.0后,自己开发的模块无法通过修改manifest.xml文件的版本号然后触发后台升级完成,实际上修改了版本号后,后台是显示升级的,但是点击升级就会提示:模块不存在或者已删除。第一步:点击升级
    ddd.jpg
    第二步:
    sss.jpg
    上面的提示是应用模块没有在开发者控制台创建应用(更没有上架);

    另外一种情况是在开发者控制台创建了应用但没有上架,还是通过本地安装模块,安装后本地修改版本号进行升级会提示:应用模块盗版。
    第一步:还是点击升级(因为修改了manifest.xml内的版本号后台就会提示升级)

    第二步:
    eded.jpg
    这里就直接开始提示盗版了!

    解决办法如下:
    1、如果要增加后台管理菜单,需要到数据库内的ims_modules_bindings表,在里面插入一行菜单即可。
    2、如果要更新版本号,到数据库内找到表ims_moudules,找到对应的模块名称,将version改为正确的版本号。
    maomivip@mail.com
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    QQ|Archiver|手机版|小黑屋|赢创志诚服务网 ( 鲁ICP备19000917号 )

    GMT+8, 2019-8-20 13:13 , Processed in 0.063430 second(s), 24 queries .

    Powered by Discuz! X3.4

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表